Upgrading is never safe!

A lot of people regularly take packages upgrades and in most cases they have no idea why. They think their system will be more up to date and more secure… they’re right, but they what they don’t realize is that every single package upgrade can potentially introduce a bug!

With an Ubuntu release every six months and one, two or three Mint releases in the meantime, do you really need security updates? Isn’t your system recent enough?

Releases are well tested, security updates and newer packages are not. Bear in mind that any kernel upgrade can potentially break your sound system, your wifi connectivity or support for any device on your computer, an Xorg update can bring you to a black screen and put your proprietary drivers on their knees…

So don’t upgrade unless you know why, and if you want to upgrade a package, then only upgrade the package, not the entire system.

In Celena we’re bringing two new things:

– mintAssistant will help you disable kernel upgrades.

– APT will be tweaked so you don’t get notified when Gutsy comes out.

You probably remember that “Upgrade to Feisty” message which popped up in Bianca… 🙂


Rick Jelliffe is right, don’t press the upgrade button!